When Trying to Install PowerShell Version 3.0 You Receive the Message: “The Update is Not Applicable to Your Computer”

You’ve decided to install PowerShell version 3.0 on your computer. Your computer meets the requirement of running Windows 7 with Service Pack 1, Windows Server 2008 with Service Pack 2, or Windows Server 2008 R2 with Service Pack 1. If you’re running Windows 8 or Windows Server 2012, you already have PowerShell version 3.0 installed.

There are several different ways to check the operating system version and service pack level. In the following screenshot, I’ve run “winver.exe” and I can see that this computer is running Windows 7 Enterprise Edition and it has Service Pack 1 installed:

The only issue with checking the operating system version with “winver.exe” is that it doesn’t show if the operating system is 32 or 64 bit which you’ll need to know in order to download the appropriate version of PowerShell 3.0 which is part of the “Windows Management Framework 3.0”. Checking the version through the control panel shows this information though:

You’ve verified your operating system meets the requirements and you’ve headed over to the Microsoft download center and located the “Windows Management Framework 3.0“. Since the machine I’m installing this on is running a 64 bit version of Windows 7, I’ll need the file shown below with the red box around it:

You’ve downloaded the file and when attempting to install it, you receive the error: “The Update is not applicable to your computer.”:

This error is due to not having the “Microsoft .NET Framework 4” installed. Download and install the .NET Framework 4 and then the installation will complete without issue. The .NET Framework 4 can be downloaded from the Microsoft Download Center:

This is the web installation version. There’s a full version if you have multiple computers or a computer without an Internet connection to install it on. It is also available as a Windows update. There’s a separate version of the .NET Framework 4 if you’re installing it on a server running the core installation (no-GUI) version of the operating system.

Update 11/4/12:
Note that you need the full version of the .NET framework 4, the client profile version as shown in the following image is not sufficient and will also cause the same error message as not having the .NET framework 4 installed:

µ

5 Comments

  1. behihoo

    Thanks so much. I was wondering why I couldn’t do this.

    Reply
  2. codingit.wordpress.com

    Thanks so much – that’s saved me an hour or two of head-banging!

    Reply
  3. RR

    Thank you. Great help

    Reply
  4. RF

    Thanks so much – was banging my head with this one!

    Reply

Leave a Reply

%d bloggers like this: